We have a disruption in Proceedo Admin

Incident Report for Proceedo

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 08:19 CEST

Investigating

We are currently investigating this issue.
Posted Apr 14, 2025 - 08:10 CEST
This incident affected: General Proceedo Availability.